aboutsummaryrefslogtreecommitdiff
path: root/data/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2021-10-15 22:42:42 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-10-21 21:55:54 +0200
commit3fc70514615c4fe2b14f33ec41be0f549e6049ee (patch)
tree0e11d173a77f4ad8c156eaeace22bfb387220b89 /data/CMakeLists.txt
parent31f4ed07cb4fe8ad6636405dc278a14b5891677a (diff)
downloadayatana-indicator-messages-3fc70514615c4fe2b14f33ec41be0f549e6049ee.tar.gz
ayatana-indicator-messages-3fc70514615c4fe2b14f33ec41be0f549e6049ee.tar.bz2
ayatana-indicator-messages-3fc70514615c4fe2b14f33ec41be0f549e6049ee.zip
Do a natural CMake file configuration
Diffstat (limited to 'data/CMakeLists.txt')
-rw-r--r--data/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
index 03fba70..76bed98 100644
--- a/data/CMakeLists.txt
+++ b/data/CMakeLists.txt
@@ -10,15 +10,13 @@ pkg_check_modules(SYSTEMD systemd)
if (${SYSTEMD_FOUND})
pkg_get_variable(SYSTEMD_USER_DIR systemd systemduserunitdir)
- set (pkglibexecdir "${CMAKE_INSTALL_FULL_LIBEXECDIR}/ayatana-indicator-messages")# Rewrite and drop once we've switched to CMake
- configure_file("${CMAKE_CURRENT_SOURCE_DIR}/ayatana-indicator-messages.service.in" "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator-messages.service")
+ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/ayatana-indicator-messages.service.in" "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator-messages.service" @ONLY)
install(FILES "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator-messages.service" DESTINATION "${SYSTEMD_USER_DIR}")
endif()
# ayatana-indicator-messages.desktop
-set(pkglibexecdir "${CMAKE_INSTALL_FULL_LIBEXECDIR}/ayatana-indicator-messages")# Rewrite and drop once we've switched to CMake
-configure_file("${CMAKE_CURRENT_SOURCE_DIR}/ayatana-indicator-messages.desktop.in" "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator-messages.desktop")
+configure_file("${CMAKE_CURRENT_SOURCE_DIR}/ayatana-indicator-messages.desktop.in" "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator-messages.desktop" @ONLY)
install(FILES "${CMAKE_CURRENT_BINARY_DIR}/ayatana-indicator-messages.desktop" DESTINATION "${CMAKE_INSTALL_FULL_SYSCONFDIR}/xdg/autostart")
# org.ayatana.indicator.messages