aboutsummaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-09-09 09:52:36 -0500
committerTed Gould <ted@canonical.com>2009-09-09 09:52:36 -0500
commit3891bd9fd2b325d18d734b4de9c52a0162cebd3b (patch)
treec49b289c316fb202c765264c7e6823efeb0b4302 /data/Makefile.am
parent5c8de01d9d2dd7167e51b60a8453737e3af49131 (diff)
downloadayatana-indicator-messages-3891bd9fd2b325d18d734b4de9c52a0162cebd3b.tar.gz
ayatana-indicator-messages-3891bd9fd2b325d18d734b4de9c52a0162cebd3b.tar.bz2
ayatana-indicator-messages-3891bd9fd2b325d18d734b4de9c52a0162cebd3b.zip
Putting the dbus service (correctly) in the libexec directory instead of the bin directory.
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 6177c6d..094a434 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -2,3 +2,9 @@ SUBDIRS = icons
dbus_servicesdir = $(DBUSSERVICEDIR)
dbus_services_DATA = indicator-messages.service
+
+%.service: %.service.in
+ sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
+
+EXTRA_DIST = indicator-messages.service.in
+