aboutsummaryrefslogtreecommitdiff
path: root/data/upstart/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2014-02-19 23:12:07 -0600
committerTed Gould <ted@gould.cx>2014-02-19 23:12:07 -0600
commit50d4a5cc6d3021397707644c63ebb96cfe23c8cb (patch)
tree151847516ebdf518f839db0f7ee5336bd0a0d896 /data/upstart/Makefile.am
parent98b1efd83f290d796c7f86a60f98495b9ee69290 (diff)
downloadayatana-indicator-messages-50d4a5cc6d3021397707644c63ebb96cfe23c8cb.tar.gz
ayatana-indicator-messages-50d4a5cc6d3021397707644c63ebb96cfe23c8cb.tar.bz2
ayatana-indicator-messages-50d4a5cc6d3021397707644c63ebb96cfe23c8cb.zip
Adding the Upstart XDG override
Diffstat (limited to 'data/upstart/Makefile.am')
-rw-r--r--data/upstart/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/data/upstart/Makefile.am b/data/upstart/Makefile.am
new file mode 100644
index 0000000..c182438
--- /dev/null
+++ b/data/upstart/Makefile.am
@@ -0,0 +1,12 @@
+
+xdg_autostartdir = $(datadir)/upstart/xdg/autostart
+xdg_autostart_DATA = indicator-messages.desktop
+
+%.desktop: %.desktop.in
+ $(AM_V_GEN) sed -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+
+EXTRA_DIST = \
+ indicator-messages.desktop.in
+
+CLEANFILES = \
+ $(xdg_autostart_DATA)