aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2021-10-19 19:38:29 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-10-21 22:21:28 +0200
commit421e9dcda36265642403c42b687e80769506b5b1 (patch)
tree61b44606d995290f8fcd062f15176a8adc8fceb1 /debian/rules
parent641e08a678c0d83fb12c78baf917857bf6367138 (diff)
downloadayatana-indicator-messages-421e9dcda36265642403c42b687e80769506b5b1.tar.gz
ayatana-indicator-messages-421e9dcda36265642403c42b687e80769506b5b1.tar.bz2
ayatana-indicator-messages-421e9dcda36265642403c42b687e80769506b5b1.zip
Update debian/ files
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules28
1 files changed, 14 insertions, 14 deletions
diff --git a/debian/rules b/debian/rules
index e97abfe..db23614 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,27 +6,27 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
-%:
- dh $@ --with autoreconf,gir,systemd
+DEB_CMAKE_EXTRA_FLAGS = \
+ -DENABLE_TESTS=ON \
+ -DENABLE_COVERAGE=OFF \
+ $(NULL)
-override_dh_autoreconf:
- if [ ! -e po/ayatana-indicator-messages.pot.bak ]; then \
- cp po/ayatana-indicator-messages.pot po/ayatana-indicator-messages.pot.bak; \
- fi
- NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+%:
+ dh $@ --with gir,systemd
override_dh_auto_configure:
- dh_auto_configure -- --enable-gtk-doc
+ dh_auto_configure -- $(DEB_CMAKE_EXTRA_FLAGS)
override_dh_install:
find debian/tmp/usr/lib -name *.la -delete
- dh_install --fail-missing
+ dh_install
+
+override_dh_missing:
+ dh_missing --fail-missing
-override_dh_auto_clean:
- dh_auto_clean
- if [ -e po/ayatana-indicator-messages.pot.bak ]; then \
- mv -f po/ayatana-indicator-messages.pot.bak po/ayatana-indicator-messages.pot; \
- fi
+# Hack as it seems it's not possible to easy run that under dbus-test-runner
+override_dh_auto_test:
+ env -u LD_PRELOAD dh_auto_test
get-orig-source:
uscan --noconf --force-download --rename --download-current-version --destdir=..