aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2011-06-22 12:49:13 -0400
committerKen VanDine <ken.vandine@canonical.com>2011-06-22 12:49:13 -0400
commita75ffde0f949f370abb98127beda432895538ff3 (patch)
tree6997c3f74c730495eeb0e44ffd9a3c5cb8c0babe /debian/rules
parentc9b60a10529bf7368508d31c89f4eb0e7df7f024 (diff)
downloadayatana-indicator-messages-a75ffde0f949f370abb98127beda432895538ff3.tar.gz
ayatana-indicator-messages-a75ffde0f949f370abb98127beda432895538ff3.tar.bz2
ayatana-indicator-messages-a75ffde0f949f370abb98127beda432895538ff3.zip
releasing version 0.4.90-0ubuntu1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules21
1 files changed, 16 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index e813915..219cf64 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,12 +1,23 @@
#!/usr/bin/make -f
+DEB_BUILDDIR = build
+DEB_MAKE_FLAVORS = gtk2 gtk3
+
include /usr/share/cdbs/1/rules/debhelper.mk
include /usr/share/cdbs/1/class/gnome.mk
-DEB_CONFIGURE_EXTRA_FLAGS += --disable-scrollkeeper
+DEB_MAKE_DESTDIRSKEL = $(CURDIR)/debian/tmp/@FLAVOR@
+DEB_DESTDIR = $(CURDIR)/debian/tmp/$(cdbs_make_curflavor)/
+
+DEB_CONFIGURE_FLAGS_gtk2 = --with-indicator-gtk=2
+DEB_CONFIGURE_FLAGS_gtk3 = --with-indicator-gtk=3
+DEB_CONFIGURE_EXTRA_FLAGS = --disable-static
+
LDFLAGS += -Wl,-z,defs -Wl,--as-needed
-binary-install/indicator-messages::
- # remove .a/.la clutter
- rm -f debian/$(cdbs_curpkg)/usr/lib/indicators/*/*.a
- rm -f debian/$(cdbs_curpkg)/usr/lib/indicators/*/*.la
+debian/stamp-autotools/gtk2: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk2)
+debian/stamp-autotools/gtk3: cdbs_configure_flags += $(DEB_CONFIGURE_FLAGS_gtk3)
+
+common-install-arch::
+ find debian/tmp -name \*.la -delete
+ find debian/tmp -name \*.a -delete