aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-03-22 23:38:18 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-03-22 23:44:19 +0100
commitf28e229d1dade11c2f1f1de3f806b266d1ff40dd (patch)
treeb99dcb81344215705bbc8d0722048a33d350f093 /debian
parent5a6ff0b1c82a77392711a8257c1cffa1e9f5678c (diff)
downloadayatana-indicator-messages-f28e229d1dade11c2f1f1de3f806b266d1ff40dd.tar.gz
ayatana-indicator-messages-f28e229d1dade11c2f1f1de3f806b266d1ff40dd.tar.bz2
ayatana-indicator-messages-f28e229d1dade11c2f1f1de3f806b266d1ff40dd.zip
debian/rules: Make sure po/ayatana-indicator-message.pot does not get lost during build.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index c0f70d7..98ccb67 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,6 +6,9 @@ export DPKG_GENSYMBOLS_CHECK_LEVEL=4
dh $@ --with autoreconf,gir
override_dh_autoreconf:
+ if [ ! -e po/ayatana-indicator-messages.pot.bak ]; then \
+ cp po/ayatana-indicator-messages.pot po/ayatana-indicator-messages.pot.bak; \
+ fi
NOCONFIGURE=1 dh_autoreconf ./autogen.sh
override_dh_auto_configure:
@@ -14,3 +17,9 @@ override_dh_auto_configure:
override_dh_install:
find debian/tmp/usr/lib -name *.la -delete
dh_install --fail-missing
+
+override_dh_auto_clean:
+ dh_auto_clean
+ if [ -e po/ayatana-indicator-messages.pot.bak ]; then \
+ mv -f po/ayatana-indicator-messages.pot.bak po/ayatana-indicator-messages.pot; \
+ fi