aboutsummaryrefslogtreecommitdiff
path: root/libmessaging-menu/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2012-06-28 16:07:17 +0200
committerLars Uebernickel <lars.uebernickel@canonical.com>2012-06-28 16:07:17 +0200
commit8f2b343fc59a927961ee90f588f207d22c54924d (patch)
treebc421ffce82fdc7f2a919c3e55753fcf490e9ad8 /libmessaging-menu/Makefile.am
parent37acacae18286dbfeceacc74db8e5ff02ae8f8b2 (diff)
downloadayatana-indicator-messages-8f2b343fc59a927961ee90f588f207d22c54924d.tar.gz
ayatana-indicator-messages-8f2b343fc59a927961ee90f588f207d22c54924d.tar.bz2
ayatana-indicator-messages-8f2b343fc59a927961ee90f588f207d22c54924d.zip
libmessaging-menu: use the (newly added) GTupleAction instead of GSimpleAction
GTupleAction is a bit simpler to handle when the action state contains a tuple of things that are independently modified most the time. It might be useful for other indicators as well. This implicitly also fixes the bug that libmessaging-menu did not preserve the other values in the action state when updating count, time, or string.
Diffstat (limited to 'libmessaging-menu/Makefile.am')
-rw-r--r--libmessaging-menu/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/libmessaging-menu/Makefile.am b/libmessaging-menu/Makefile.am
index a0da51e..becaded 100644
--- a/libmessaging-menu/Makefile.am
+++ b/libmessaging-menu/Makefile.am
@@ -5,6 +5,8 @@ libmessaging_menu_ladir = $(includedir)/messaging-menu
libmessaging_menu_la_SOURCES = \
messaging-menu.c \
+ gtupleaction.c \
+ gtupleaction.h \
$(BUILT_SOURCES)
libmessaging_menu_la_HEADERS = \