aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2012-06-27 21:42:23 +0200
committerLars Uebernickel <lars.uebernickel@canonical.com>2012-06-27 21:42:23 +0200
commit193886f467b636a91d546656017de3fd0fa62677 (patch)
treea8ef69e6ee47dddb6c746c0f65ce19daa86118f2 /src/Makefile.am
parent315c058bcc7c152615cf35f11c0f29d8ee9ec01b (diff)
downloadayatana-indicator-messages-193886f467b636a91d546656017de3fd0fa62677.tar.gz
ayatana-indicator-messages-193886f467b636a91d546656017de3fd0fa62677.tar.bz2
ayatana-indicator-messages-193886f467b636a91d546656017de3fd0fa62677.zip
Use gdbus-codegen also for the server side messages service
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am30
1 files changed, 13 insertions, 17 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e9f88e6..1bc5b59 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -15,8 +15,8 @@ messaginglibdir = $(INDICATORDIR)
messaginglib_LTLIBRARIES = libmessaging.la
libmessaging_la_SOURCES = \
indicator-messages.c \
- gen-messages-service.xml.h \
- gen-messages-service.xml.c \
+ indicator-messages-service.c \
+ indicator-messages-service.h
dbus-data.h
libmessaging_la_CFLAGS = \
$(APPLET_CFLAGS) \
@@ -38,10 +38,8 @@ libmessaging_la_LDFLAGS = \
indicator_messages_service_SOURCES = \
messages-service.c \
- messages-service-dbus.c \
- messages-service-dbus.h \
- gen-messages-service.xml.h \
- gen-messages-service.xml.c \
+ indicator-messages-service.c \
+ indicator-messages-service.h \
app-section.c \
app-section.h \
dbus-data.h \
@@ -68,19 +66,17 @@ indicator_messages_service_LDADD = \
indicator_messages_service_LDFLAGS = \
$(COVERAGE_LDFLAGS)
-gen-%.xml.h: %.xml
- @echo "Building $@ from $<"
- @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<))));" > $@
-
-gen-%.xml.c: %.xml
- @echo "Building $@ from $<"
- echo "const char * _$(subst -,_,$(subst .,_,$(basename $(notdir $<)))) = " > $@
- @sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
- @echo ";" >> $@
+indicator-messages-service.c: $(top_srcdir)/src/messages-service.xml
+ $(AM_V_GEN) gdbus-codegen \
+ --interface-prefix com.canonical.indicator.messages. \
+ --generate-c-code indicator-messages-service \
+ --c-namespace IndicatorMessages \
+ $^
+indicator-messages-service.h: indicator-messages-service.c
BUILT_SOURCES += \
- gen-messages-service.xml.h \
- gen-messages-service.xml.c
+ indicator-messages-service.c \
+ indicator-messages-service.h
EXTRA_DIST += \
messages-service.xml