aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2012-11-20 22:20:23 +0100
committerLars Uebernickel <lars.uebernickel@canonical.com>2012-11-20 22:20:23 +0100
commit2021da310c84d28efcf9bb359b7a8f7065743267 (patch)
treea3b1f70e0eaad9fc75218c7269a1267bcc6f1704 /src/Makefile.am
parent6f990698f610eb444845f36a70cad04bca2415f3 (diff)
downloadayatana-indicator-messages-2021da310c84d28efcf9bb359b7a8f7065743267.tar.gz
ayatana-indicator-messages-2021da310c84d28efcf9bb359b7a8f7065743267.tar.bz2
ayatana-indicator-messages-2021da310c84d28efcf9bb359b7a8f7065743267.zip
messages-service: move app handling into separate class
Add ImApplicationList, a class that manages the list of applictions that are currently registered with the messaging menu. It creates dbus proxies for running applications and sends signals when the app adds messages or sources.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 12c8031..5d8bad8 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -54,7 +54,9 @@ indicator_messages_service_SOURCES = \
gmenuutils.c \
gmenuutils.h \
im-phone-menu.c \
- im-phone-menu.h
+ im-phone-menu.h \
+ im-application-list.c \
+ im-application-list.h
indicator_messages_service_CFLAGS = \
$(APPLET_CFLAGS) \