aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-07-08 14:46:06 -0500
committerTed Gould <ted@gould.cx>2011-07-08 14:46:06 -0500
commit3e9685c57d9df7a353431d0b89138309816dee5b (patch)
tree5ee0e66dc10563aac07fb44ecef1faedea709fee /src/Makefile.am
parent7a1cef803be9893e30d6e4e9ba4147e43cf38319 (diff)
downloadayatana-indicator-messages-3e9685c57d9df7a353431d0b89138309816dee5b.tar.gz
ayatana-indicator-messages-3e9685c57d9df7a353431d0b89138309816dee5b.tar.bz2
ayatana-indicator-messages-3e9685c57d9df7a353431d0b89138309816dee5b.zip
Making a pkgconfig file for the status providers
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 62159cb..c631436 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,8 @@
BUILT_SOURCES =
EXTRA_DIST =
+CLEANFILES =
+DISTCLEANFILES =
libexec_PROGRAMS = indicator-messages-service
@@ -93,6 +95,20 @@ STATUS_PROVIDER_DIR = $(libexecdir)/status-providers/$(STATUS_PROVIDER_API_VERSI
statusprovidersdir = $(STATUS_PROVIDER_DIR)
statusproviders_LTLIBRARIES =
+EXTRA_DIST += \
+ indicator-messages-status-provider-0.5.pc.in.in
+CLEANFILES += \
+ indicator-messages-status-provider-0.5.pc
+
+pkgconfig_DATA = indicator-messages-status-provider-0.5.pc
+pkgconfigdir = $(libdir)/pkgconfig
+
+%.pc: %.pc.in
+ sed \
+ -e "s|\@status_provider_dir\@|$(STATUS_PROVIDER_DIR)|" \
+ -e "s|\@status_provider_api_version\@|$(STATUS_PROVIDER_API_VERSION)|" \
+ $< > $@
+
lib_LTLIBRARIES = \
libindicator-messages-status-provider.la
@@ -255,6 +271,6 @@ libemesene_la_LDFLAGS = -module -avoid-version
# Extras
######################################
-CLEANFILES = \
+CLEANFILES += \
$(BUILT_SOURCES)