aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2012-06-03 08:33:31 +0200
committerLars Uebernickel <lars.uebernickel@canonical.com>2012-06-03 08:33:31 +0200
commit6872c840672049695904d61c1a3baba22c6d9627 (patch)
treed2393b4131adc1508f14c3977ef0d854ca36a25f /src/Makefile.am
parenta6d889c175d136cfb1d63a9c04bb2156f210a09e (diff)
downloadayatana-indicator-messages-6872c840672049695904d61c1a3baba22c6d9627.tar.gz
ayatana-indicator-messages-6872c840672049695904d61c1a3baba22c6d9627.tar.bz2
ayatana-indicator-messages-6872c840672049695904d61c1a3baba22c6d9627.zip
Add GActionMuxer
This is a new implementation of an action muxer with the same interface as the one in the gtk tree. Its implementation is considerably simpler, mostly because it doesn't need to implement GActionObservable. In addition to muxing different action groups with the <prefix>.<action_name> scheme, it has the notion of global, prefix-less actions. Indicator-messages needs those for the status and clear actions.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1dbb514..183d729 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -45,9 +45,10 @@ indicator_messages_service_SOURCES = \
app-section.c \
app-section.h \
dbus-data.h \
- \
status-items.c \
- status-items.h
+ status-items.h \
+ gactionmuxer.c \
+ gactionmuxer.h
indicator_messages_service_CFLAGS = \
$(APPLET_CFLAGS) \