aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@canonical.com>2009-08-04 12:37:58 +0100
committerTed Gould <ted@canonical.com>2009-08-04 12:37:58 +0100
commitb99103376be47ed4d1b2a74c2abc441141bc8107 (patch)
treeb6c00a3a48f2df630a71766748bdc13e88b74838 /src/Makefile.am
parente6c51e39309fe1f951df75ee80a43b12ed3e4265 (diff)
parent7bd2ed28f7657191beb001f60109167ab1644a57 (diff)
downloadayatana-indicator-messages-b99103376be47ed4d1b2a74c2abc441141bc8107.tar.gz
ayatana-indicator-messages-b99103376be47ed4d1b2a74c2abc441141bc8107.tar.bz2
ayatana-indicator-messages-b99103376be47ed4d1b2a74c2abc441141bc8107.zip
Merging in the branch that pulls in the dbusmenu changes that change to using a service.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 986e89d..74db2df 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,7 +1,13 @@
+bin_PROGRAMS = indicator-messages-service
+
messaginglibdir = $(INDICATORDIR)
messaginglib_LTLIBRARIES = libmessaging.la
libmessaging_la_SOURCES = indicator-messages.c im-menu-item.c im-menu-item.h app-menu-item.c app-menu-item.h
-libmessaging_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Wl,-Bsymbolic-functions -Wl,-z,defs -Wl,--as-needed
+libmessaging_la_CFLAGS = $(APPLET_CFLAGS) -Wall -Wl,-Bsymbolic-functions -Wl,-z,defs -Wl,--as-needed -Werror
libmessaging_la_LIBADD = $(APPLET_LIBS)
libmessaging_la_LDFLAGS = -module -avoid-version
+
+indicator_messages_service_SOURCES = indicator-service.c im-menu-item.c im-menu-item.h app-menu-item.c app-menu-item.h
+indicator_messages_service_CFLAGS = $(APPLET_CFLAGS) -Wall -Wl,-Bsymbolic-functions -Wl,-z,defs -Wl,--as-needed -Werror
+indicator_messages_service_LDADD = $(APPLET_LIBS)