aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2011-06-22 15:42:44 -0500
committerTed Gould <ted@gould.cx>2011-06-22 15:42:44 -0500
commitc6055d45604745ac063db2d1daf8207df5c7fad5 (patch)
tree6561b5da466917a25a85329fba02710c247311f3 /src/Makefile.am
parent4fed4ff3571e8ddcbdad352b99d53bd092d2475b (diff)
downloadayatana-indicator-messages-c6055d45604745ac063db2d1daf8207df5c7fad5.tar.gz
ayatana-indicator-messages-c6055d45604745ac063db2d1daf8207df5c7fad5.tar.bz2
ayatana-indicator-messages-c6055d45604745ac063db2d1daf8207df5c7fad5.zip
Stealing all of the status providers from indicator-me so that we can use them here.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am159
1 files changed, 153 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8597d77..8e4f170 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,14 @@
+BUILT_SOURCES =
+EXTRA_DIST =
+
libexec_PROGRAMS = indicator-messages-service
+STATUS_PROVIDER_API_VERSION = 1
+STATUS_PROVIDER_DIR = $(libexecdir)/status-providers/$(STATUS_PROVIDER_API_VERSION)/
+statusprovidersdir = $(STATUS_PROVIDER_DIR)
+statusproviders_LTLIBRARIES =
+
######################################
# Building the messages indicator
######################################
@@ -44,7 +52,11 @@ indicator_messages_service_SOURCES = \
seen-db.c \
seen-db.h \
dirs.h \
- dbus-data.h
+ dbus-data.h \
+ \
+ status-provider.c \
+ status-provider.h
+
indicator_messages_service_CFLAGS = \
$(APPLET_CFLAGS) \
-Wall \
@@ -52,7 +64,9 @@ indicator_messages_service_CFLAGS = \
-Wl,-z,defs \
-Wl,--as-needed \
-Werror \
- -DG_LOG_DOMAIN=\"Indicator-Messages\"
+ -DG_LOG_DOMAIN=\"Indicator-Messages\" \
+ -DSTAUTS_PROVIDER_DIR=\"$(STATUS_PROVIDER_DIR)\"
+
indicator_messages_service_LDADD = $(APPLET_LIBS)
gen-%.xml.h: %.xml
@@ -65,13 +79,146 @@ gen-%.xml.c: %.xml
@sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
@echo ";" >> $@
-BUILT_SOURCES = \
+BUILT_SOURCES += \
gen-messages-service.xml.h \
gen-messages-service.xml.c
+EXTRA_DIST += \
+ messages-service.xml
+
+######################################
+# Status provider: Pidgin
+######################################
+
+statusproviders_LTLIBRARIES += libpidgin.la
+libpidgin_la_SOURCES = \
+ status-provider-pidgin.h \
+ status-provider-pidgin.c \
+ status-provider-pidgin-marshal.h \
+ status-provider-pidgin-marshal.c
+libpidgin_la_CFLAGS = \
+ $(APPLET_CFLAGS) \
+ $(STATUS_PROVIDER_PIDGIN_CFLAGS) \
+ -Wall -Werror \
+ -DG_LOG_DOMAIN=\"Status-Provider-Pidgin\"
+libpidgin_la_LIBADD = \
+ $(APPLET_LIBS) \
+ $(STATUS_PROVIDER_PIDGIN_LIBS)
+libpidgin_la_LDFLAGS = -module -avoid-version
+
+status-provider-pidgin-marshal.h: $(srcdir)/status-provider-pidgin.list
+ glib-genmarshal --header \
+ --prefix=_status_provider_pidgin_marshal $(srcdir)/status-provider-pidgin.list \
+ > status-provider-pidgin-marshal.h
+
+status-provider-pidgin-marshal.c: $(srcdir)/status-provider-pidgin.list
+ glib-genmarshal --body \
+ --prefix=_status_provider_pidgin_marshal $(srcdir)/status-provider-pidgin.list \
+ > status-provider-pidgin-marshal.c
+
+BUILT_SOURCES += \
+ status-provider-pidgin-marshal.h \
+ status-provider-pidgin-marshal.c
+
+EXTRA_DIST += \
+ status-provider-pidgin.list
+
+######################################
+# Status provider: Mission Control 4
+######################################
+
+statusproviders_LTLIBRARIES += libtelepathy.la
+libtelepathy_la_SOURCES = \
+ status-provider-telepathy.h \
+ status-provider-telepathy.c \
+ status-provider-telepathy-marshal.h \
+ status-provider-telepathy-marshal.c
+libtelepathy_la_CFLAGS = \
+ $(APPLET_CFLAGS) \
+ $(STATUS_PROVIDER_TELEPATHY_CFLAGS) \
+ -Wall -Werror \
+ -DG_LOG_DOMAIN=\"Status-Provider-Telepathy\"
+libtelepathy_la_LIBADD = \
+ $(APPLET_LIBS) \
+ $(STATUS_PROVIDER_TELEPATHY_LIBS)
+libtelepathy_la_LDFLAGS = -module -avoid-version
+
+status-provider-telepathy-marshal.h: $(srcdir)/status-provider-telepathy.list
+ glib-genmarshal --header \
+ --prefix=_status_provider_telepathy_marshal $(srcdir)/status-provider-telepathy.list \
+ > status-provider-telepathy-marshal.h
+
+status-provider-telepathy-marshal.c: $(srcdir)/status-provider-telepathy.list
+ glib-genmarshal --body \
+ --prefix=_status_provider_telepathy_marshal $(srcdir)/status-provider-telepathy.list \
+ > status-provider-telepathy-marshal.c
+
+BUILT_SOURCES += \
+ status-provider-telepathy-marshal.h \
+ status-provider-telepathy-marshal.c
+
+EXTRA_DIST += \
+ status-provider-telepathy.list
+
+######################################
+# Status provider: Mission Control 5
+######################################
+
+statusproviders_LTLIBRARIES += libmc5.la
+libmc5_la_SOURCES = \
+ status-provider-mc5.h \
+ status-provider-mc5.c \
+ status-provider-mc5-marshal.h \
+ status-provider-mc5-marshal.c
+libmc5_la_CFLAGS = \
+ $(APPLET_CFLAGS) \
+ $(STATUS_PROVIDER_MC5_CFLAGS) \
+ -Wall -Werror \
+ -DG_LOG_DOMAIN=\"Status-Provider-MC5\"
+libmc5_la_LIBADD = \
+ $(APPLET_LIBS) \
+ $(STATUS_PROVIDER_MC5_LIBS)
+libmc5_la_LDFLAGS = -module -avoid-version
+
+status-provider-mc5-marshal.h: $(srcdir)/status-provider-mc5.list
+ glib-genmarshal --header \
+ --prefix=_status_provider_mc5_marshal $(srcdir)/status-provider-mc5.list \
+ > status-provider-mc5-marshal.h
+
+status-provider-mc5-marshal.c: $(srcdir)/status-provider-mc5.list
+ glib-genmarshal --body \
+ --prefix=_status_provider_mc5_marshal $(srcdir)/status-provider-mc5.list \
+ > status-provider-mc5-marshal.c
+
+BUILT_SOURCES += \
+ status-provider-mc5-marshal.h \
+ status-provider-mc5-marshal.c
+
+EXTRA_DIST += \
+ status-provider-mc5.list
+
+######################################
+# Status provider: Emesene
+######################################
+
+statusproviders_LTLIBRARIES += libemesene.la
+libemesene_la_SOURCES = \
+ status-provider-emesene.h \
+ status-provider-emesene.c
+libemesene_la_CFLAGS = \
+ $(APPLET_CFLAGS) \
+ $(STATUS_PROVIDER_EMESENE_CFLAGS) \
+ -Wall -Werror \
+ -DG_LOG_DOMAIN=\"Status-Provider-Emesene\"
+libemesene_la_LIBADD = \
+ $(APPLET_LIBS) \
+ $(STATUS_PROVIDER_EMESENE_LIBS)
+libemesene_la_LDFLAGS = -module -avoid-version
+
+######################################
+# Extras
+######################################
+
CLEANFILES = \
$(BUILT_SOURCES)
-EXTRA_DIST = \
- messages-service.xml
-