aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLars Uebernickel <lars.uebernickel@canonical.com>2012-08-27 15:38:04 +0200
committerLars Uebernickel <lars.uebernickel@canonical.com>2012-08-27 15:38:04 +0200
commitfab67a704ed6f189014a1988e641194e0f4babb1 (patch)
tree72dc7fbd55c4f805ea58f0e2cd93c081cd09249c /src/Makefile.am
parent26e95dd525ecee8024bcee0e45730798e08c877a (diff)
downloadayatana-indicator-messages-fab67a704ed6f189014a1988e641194e0f4babb1.tar.gz
ayatana-indicator-messages-fab67a704ed6f189014a1988e641194e0f4babb1.tar.bz2
ayatana-indicator-messages-fab67a704ed6f189014a1988e641194e0f4babb1.zip
Show icons on status menu items
This introduces IdoMenuItem, a GtkCheckMenuItem that can also show icons. This should go into libido at some point. Also, Im{App,Source}MenuItem could derive from it so that the GMenuItem-setting logic is only in one place.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 403a289..4d86730 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -15,6 +15,8 @@ messaginglibdir = $(INDICATORDIR)
messaginglib_LTLIBRARIES = libmessaging.la
libmessaging_la_SOURCES = \
indicator-messages.c \
+ ido-menu-item.c \
+ ido-menu-item.h \
im-app-menu-item.c \
im-app-menu-item.h \
im-source-menu-item.c \