aboutsummaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAllan LeSage <allanlesage@gmail.com>2012-03-16 16:11:07 -0500
committerAllan LeSage <allanlesage@gmail.com>2012-03-16 16:11:07 -0500
commita5695b6ae268abc5c446a734ea8dbbcc30bc47fb (patch)
tree47ee4693c6dd9c5c0094c047174bf2643026b4de /test/Makefile.am
parentbacad6ee225001ec39b6263ceb4aa99d55a67ba6 (diff)
downloadayatana-indicator-messages-a5695b6ae268abc5c446a734ea8dbbcc30bc47fb.tar.gz
ayatana-indicator-messages-a5695b6ae268abc5c446a734ea8dbbcc30bc47fb.tar.bz2
ayatana-indicator-messages-a5695b6ae268abc5c446a734ea8dbbcc30bc47fb.zip
Experimental Makefile.am changes to support GTest.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 7b59f54..e262bae 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -18,10 +18,12 @@ libgtest_a_CXXFLAGS = \
TESTS += test-gtest
test_gtest_SOURCES = \
+ $(top_srcdir)/src/launcher-menu-item.c \
+ $(top_srcdir)/src/default-applications.c \
+ $(top_srcdir)/src/seen-db.c \
test-gtest.cpp
test_gtest_CPPFLAGS = \
- $(APPLET_CFLAGS) \
- -I$(top_srcdir)/src
+ $(APPLET_CFLAGS)
test_gtest_LDFLAGS = -pthread
test_gtest_LDADD = \
$(APPLET_LIBS) \