aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTed Gould <ted@gould.cx>2015-03-06 21:46:30 -0600
committerTed Gould <ted@gould.cx>2015-03-06 21:46:30 -0600
commit474099ef1d4010fa918da698707b644cbc3fe5da (patch)
tree264ae602ee1390949470bbbfac13e39a92d6ca00 /tests/Makefile.am
parentdf3f745d94c5bd0c5c0c2eaf85ed63a438981e3d (diff)
downloadayatana-indicator-messages-474099ef1d4010fa918da698707b644cbc3fe5da.tar.gz
ayatana-indicator-messages-474099ef1d4010fa918da698707b644cbc3fe5da.tar.bz2
ayatana-indicator-messages-474099ef1d4010fa918da698707b644cbc3fe5da.zip
A test that puts a message in the menu
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ee0b9d7..6dabf89 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -47,6 +47,8 @@ indicator_test_SOURCES = \
indicator_test_CPPFLAGS = \
-DINDICATOR_MESSAGES_SERVICE_BINARY="\"$(abs_top_builddir)/src/indicator-messages-service\"" \
-DSCHEMA_DIR="\"$(abs_builddir)/gsettings-schemas-compiled/\"" \
+ -DXDG_DATA_DIRS="\"$(abs_srcdir)/\"" \
+ -I$(top_srcdir)/libmessaging-menu \
-std=c++11 \
$(APPLET_CFLAGS) \
$(DBUSTEST_CFLAGS) \
@@ -55,6 +57,7 @@ indicator_test_CPPFLAGS = \
indicator_test_LDADD = \
$(APPLET_LIBS) \
$(DBUSTEST_LIBS) \
+ $(top_builddir)/libmessaging-menu/libmessaging-menu.la \
libgtest.la \
-lc -lpthread