aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a5ca692..a429d17 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,6 +77,15 @@ AC_SUBST(APPLET_CFLAGS)
AC_SUBST(APPLET_LIBS)
###########################
+# Test Dependencies
+###########################
+
+AC_ARG_ENABLE([tests],
+ AC_HELP_STRING([--disable-tests], [Disable test scripts and tools]),,
+ [enable_tests=auto])
+AM_CONDITIONAL(BUILD_TESTS, test xyes = xyes)
+
+###########################
# Status Provider Deps
###########################
@@ -117,7 +126,6 @@ AC_SUBST(COVERAGE_LDFLAGS)
m4_include([m4/gtest.m4])
CHECK_GTEST
-AM_CONDITIONAL([HAVE_GTEST], [test "x$have_gtest" = xyes])
###########################
# Check to see if we're local