aboutsummaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am17
1 files changed, 16 insertions, 1 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index ff45ba2..b88aee5 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -1,3 +1,5 @@
+NULL =
+
SUBDIRS = icons
xdg_autostartdir = /etc/xdg/autostart
@@ -9,12 +11,25 @@ xdg_autostart_DATA = ayatana-indicator-messages.desktop
gsettings_SCHEMAS = org.ayatana.indicator.messages.gschema.xml
@GSETTINGS_RULES@
+#if defined(HAVE_SYSTEMD)
+systemdservice_file = ayatana-indicator-messages.service
+$(systemdservice_file): $(systemdservice_file).in
+ $(AM_V_GEN) sed -e "s|\@pkglibexecdir\@|$(pkglibexecdir)|" $< > $@
+
+systemddir = $(SYSTEMD_USERDIR)
+systemd_DATA = $(systemdservice_file)
+#endif
+
indicatordir = $(INDICATOR_DIR)
dist_indicator_DATA = org.ayatana.indicator.messages
EXTRA_DIST = \
ayatana-indicator-messages.desktop.in \
- $(gsettings_SCHEMAS)
+ $(gsettings_SCHEMAS) \
+ $(systemdservice_file).in \
+ $(NULL)
CLEANFILES = \
$(xdg_autostart_DATA) \
+ $(systemdservice_file) \
+ $(NULL)