aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJason Conti <jason.conti@gmail.com>2011-05-07 12:31:24 -0400
committerJason Conti <jason.conti@gmail.com>2011-05-07 12:31:24 -0400
commitea9ddbaa810db9fa91969afb693c4d27778a0a6d (patch)
tree7f3c7f22ae1fabebe697626315ad13d203f2f75e /Makefile.am
downloadayatana-indicator-notifications-ea9ddbaa810db9fa91969afb693c4d27778a0a6d.tar.gz
ayatana-indicator-notifications-ea9ddbaa810db9fa91969afb693c4d27778a0a6d.tar.bz2
ayatana-indicator-notifications-ea9ddbaa810db9fa91969afb693c4d27778a0a6d.zip
Import from lp:indicator-datetime
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..4de650a
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,37 @@
+
+SUBDIRS = \
+ libmap \
+ src \
+ data \
+ tests \
+ po
+
+DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall
+
+EXTRA_DIST = autogen.sh
+
+dist-hook:
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --gnu-changelog ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(top_distdir)/ChangeLog \
+ || (rm -f ChangeLog.tmp; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo Failed to generate ChangeLog: not a branch >&2; \
+ fi
+ @if test -d "$(top_srcdir)/.bzr"; \
+ then \
+ echo Creating AUTHORS && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run bzr log --long --levels=0 | grep -e "^\s*author:" -e "^\s*committer:" | cut -d ":" -f 2 | cut -d "<" -f 1 | sort -u) > AUTHORS.tmp \
+ && mv -f AUTHORS.tmp $(top_distdir)/AUTHORS \
+ || (rm -f AUTHORS.tmp; \
+ echo Failed to generate AUTHORS >&2 ); \
+ else \
+ echo Failed to generate AUTHORS: not a branch >&2; \
+ fi