aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-06 12:01:21 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-06 12:04:32 +0100
commit4053ab0a968ca580edc670536b9d85431e7870fc (patch)
tree2feb4247064960c3e4b0f27bbcb63dcff9937b55 /configure.ac
parent84fb494bf2da26fb2071d26a3e1a3f0e34d9ba50 (diff)
downloadayatana-indicator-notifications-4053ab0a968ca580edc670536b9d85431e7870fc.tar.gz
ayatana-indicator-notifications-4053ab0a968ca580edc670536b9d85431e7870fc.tar.bz2
ayatana-indicator-notifications-4053ab0a968ca580edc670536b9d85431e7870fc.zip
Enable locale support at runtime.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b989545..75a55fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,10 +16,24 @@ AC_PROG_LIBTOOL
# Setup gettext with intltool
+AC_DEFUN([AC_DEFINE_PATH], [
+ test "x$prefix" = xNONE && prefix="$ac_default_prefix"
+ test "x$exec_prefix" = xNONE && exec_prefix='${prefix}'
+ ac_define_path=`eval echo [$]$2`
+ ac_define_path=`eval echo [$]ac_define_path`
+ $1="$ac_define_path"
+ AC_SUBST($1)
+ ifelse($3, ,
+ AC_DEFINE_UNQUOTED($1, "$ac_define_path"),
+ AC_DEFINE_UNQUOTED($1, "$ac_define_path", $3))
+])
+
IT_PROG_INTLTOOL
GETTEXT_PACKAGE=ayatana-indicator-notifications
-AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], ["$GETTEXT_PACKAGE"], [Gettext package])
AC_SUBST(GETTEXT_PACKAGE)
+AC_DEFINE_UNQUOTED([GETTEXT_PACKAGE], ["$GETTEXT_PACKAGE"], [Gettext package])
+AC_DEFINE_PATH([LOCALEDIR], "${datadir}/locale", [locale directory])
+AM_GLIB_GNU_GETTEXT
# Helpers for GSettings