aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Conti <jason.conti@gmail.com>2011-08-19 13:32:25 -0400
committerJason Conti <jason.conti@gmail.com>2011-08-19 13:32:25 -0400
commit59896497977040f03aaa0b2c293c265ed2e0c4e7 (patch)
tree4008e7001eb4835bdebc008162031df761a7434f /configure.ac
parentc5ac5ce87d42d4456da3c82da1aed0ddece36129 (diff)
downloadayatana-indicator-notifications-59896497977040f03aaa0b2c293c265ed2e0c4e7.tar.gz
ayatana-indicator-notifications-59896497977040f03aaa0b2c293c265ed2e0c4e7.tar.bz2
ayatana-indicator-notifications-59896497977040f03aaa0b2c293c265ed2e0c4e7.zip
* Add a WITH_GTK (2, 3) definition to handle some of the minor differences0.1.3
between gtk2 and 3 * Replace gtk_hbox_new with gtk_box_new in the gtk3 version * GtkLabel has a new (and much nicer) wrapping mechanism - use gtk_label_set_max_width_chars in gtk3 version
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 79bb0dc..0226b58 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,9 +42,12 @@ PKG_PROG_PKG_CONFIG
AC_ARG_WITH([gtk],
[AS_HELP_STRING([--with-gtk],
- [Which version of gtk to use @<:@default=2@:>@])],
+ [Which version of gtk to use @<:@default=3@:>@])],
[],
- [with_gtk=2])
+ [with_gtk=3])
+
+GTK_VERSION=$with_gtk
+AC_SUBST(GTK_VERSION)
###########################
# Dependencies