aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-02 19:18:59 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-02 19:18:59 +0100
commit6bc2b280c349851a05f28ca4b06fe5d51c59bea0 (patch)
tree6ad296b2792b4fa70a309f9e9bbdb3c6fabfb69c /configure.ac
parent27a4b02329b62efffa89419d73be7c1f10838d76 (diff)
downloadayatana-indicator-notifications-6bc2b280c349851a05f28ca4b06fe5d51c59bea0.tar.gz
ayatana-indicator-notifications-6bc2b280c349851a05f28ca4b06fe5d51c59bea0.tar.bz2
ayatana-indicator-notifications-6bc2b280c349851a05f28ca4b06fe5d51c59bea0.zip
Convert to Ayatana Indicators.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 3 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 3ec1f55..fc2e4fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-AC_INIT([indicator-notifications], [0.3.3], [jason.conti@gmail.com])
+AC_INIT([ayatana-indicator-notifications], [0.4.0], [jason.conti@gmail.com])
AM_INIT_AUTOMAKE([-Wall -Werror])
@@ -30,7 +30,7 @@ GLIB_GSETTINGS
INDICATOR_REQUIRED_VERSION=0.3.19
GTK3_REQUIRED_VERSION=3.0
-INDICATOR3_PKG_NAME=indicator3-0.4
+INDICATOR3_PKG_NAME=ayatana-indicator3-0.4
PKG_CHECK_MODULES(INDICATOR, $INDICATOR3_PKG_NAME >= $INDICATOR_REQUIRED_VERSION
gtk+-3.0 >= GTK3_REQUIRED_VERSION)
@@ -40,18 +40,7 @@ AC_SUBST(INDICATOR_LIBS)
# Library directories from pkg-config
-with_localinstall="no"
-AC_ARG_ENABLE([localinstall],
- [AS_HELP_STRING([--enable-localinstall],
- [set default library directories instead of asking pkg-config (default is no)])],
- [with_localinstall="yes"],
- [with_localinstall="no"])
-
-if test "x$with_localinstall" = "xyes"; then
- INDICATORDIR="${libdir}/indicators/2/"
-else
- INDICATORDIR=`$PKG_CONFIG --variable=indicatordir $INDICATOR3_PKG_NAME`
-fi
+INDICATORDIR=`$PKG_CONFIG --variable=indicatordir $INDICATOR3_PKG_NAME`
INDICATORICONSDIR="${datadir}/pixmaps/"
AC_SUBST(INDICATORDIR)