aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-08-10 10:07:58 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-08-10 10:07:58 +0200
commit8189b651e2ab4b22fb2c471e8436e93cb914a49b (patch)
treef6c3c0e7d555b6e6838489e5a6c5f2de41579a24 /configure.ac
parentac5d6867a8ce34b8a77bf5545bbb4b36f8bafb15 (diff)
downloadayatana-indicator-notifications-8189b651e2ab4b22fb2c471e8436e93cb914a49b.tar.gz
ayatana-indicator-notifications-8189b651e2ab4b22fb2c471e8436e93cb914a49b.tar.bz2
ayatana-indicator-notifications-8189b651e2ab4b22fb2c471e8436e93cb914a49b.zip
Start indicator in systemd when ayatana-indicators.target is started.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e9bc3bd..8b3b48b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,6 +65,19 @@ PKG_CHECK_MODULES(SETTINGS, gtk+-3.0 >= GTK3_REQUIRED_VERSION)
AC_SUBST(SETTINGS_CFLAGS)
AC_SUBST(SETTINGS_LIBS)
+#########################
+# Check for systemd
+#########################
+PKG_CHECK_MODULES(SYSTEMD, systemd,
+ [has_systemd=yes],
+ []
+)
+if test "x$has_systemd" = "xyes"; then
+ SYSTEMD_USERDIR=`$PKG_CONFIG --variable=systemduserunitdir systemd`
+ AC_SUBST(SYSTEMD_USERDIR)
+ AC_DEFINE(HAVE_SYSTEMD, 1, [create ayatana-indicator-application.service for systemd])
+fi
+
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([
Makefile