aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Conti <jason.conti@gmail.com>2011-05-19 20:41:30 -0400
committerJason Conti <jason.conti@gmail.com>2011-05-19 20:41:30 -0400
commita25826c9b9ff0d74f26208f442d14b9f3285bf36 (patch)
tree99cddcd968960cff58e42e46ff074387fcc89ea5 /configure.ac
parent88c859aeafcc3bb452a5da2a084dbaaebc0139f3 (diff)
downloadayatana-indicator-notifications-a25826c9b9ff0d74f26208f442d14b9f3285bf36.tar.gz
ayatana-indicator-notifications-a25826c9b9ff0d74f26208f442d14b9f3285bf36.tar.bz2
ayatana-indicator-notifications-a25826c9b9ff0d74f26208f442d14b9f3285bf36.zip
Bumping version and removing some unnecessary dependencies.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 7 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index e1f352f..fbc471d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,10 +1,10 @@
-AC_INIT(indicator-notifications, 0.1.0, jason.conti@gmail.com)
+AC_INIT(indicator-notifications, 0.1.1, jason.conti@gmail.com)
AC_PREREQ(2.53)
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(indicator-notifications, 0.1.0)
+AM_INIT_AUTOMAKE(indicator-notifications, 0.1.1)
AM_MAINTAINER_MODE
@@ -55,8 +55,7 @@ DBUSMENUGLIB_REQUIRED_VERSION=0.1.1
DBUSMENUGTK_REQUIRED_VERSION=0.3.94
GIO_REQUIRED_VERSION=2.25.11
# Note: the GIO check below also ensures the proper glib with gsettings support is present
-INDICATOR_DISPLAY_OBJECTS=0.2.2
-GDK_REQUIRED_VERSION=2.22
+#GDK_REQUIRED_VERSION=2.22
GDK_PIXBUF_REQUIRED_VERSION=2.22
GLIB_REQUIRED_VERSION=2.26
GTK_REQUIRED_VERSION=2.12
@@ -66,16 +65,14 @@ AS_IF([test "x$with_gtk" = x3],
[PKG_CHECK_MODULES(INDICATOR, indicator3 >= $INDICATOR_REQUIRED_VERSION
glib-2.0 >= $GLIB_REQUIRED_VERSION
dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION
- dbusmenu-gtk3-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION
- libido3-0.1 >= $INDICATOR_DISPLAY_OBJECTS)
+ dbusmenu-gtk3-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION)
],
[test "x$with_gtk" = x2],
[PKG_CHECK_MODULES(INDICATOR, indicator >= $INDICATOR_REQUIRED_VERSION
glib-2.0 >= $GLIB_REQUIRED_VERSION
dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION
dbusmenu-gtk-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION
- gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED_VERSION
- libido-0.1 >= $INDICATOR_DISPLAY_OBJECTS)
+ gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED_VERSION)
],
[AC_MSG_FAILURE([Value for --with-gtk was neither 2 nor 3])]
)
@@ -85,19 +82,14 @@ AS_IF([test "x$with_gtk" = x3],
glib-2.0 >= $GLIB_REQUIRED_VERSION
dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION
dbusmenu-gtk3-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION
- libido-0.1 >= $INDICATOR_DISPLAY_OBJECTS
- gio-2.0 >= $GIO_REQUIRED_VERSION
- gdk-2.0 >= GDK_REQUIRED_VERSION)
+ gio-2.0 >= $GIO_REQUIRED_VERSION)
],
[test "x$with_gtk" = x2],
[PKG_CHECK_MODULES(SERVICE, indicator >= $INDICATOR_REQUIRED_VERSION
glib-2.0 >= $GLIB_REQUIRED_VERSION
dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION
dbusmenu-gtk-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION
- libido-0.1 >= $INDICATOR_DISPLAY_OBJECTS
- gio-2.0 >= $GIO_REQUIRED_VERSION
- gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED_VERSION
- gdk-2.0 >= GDK_REQUIRED_VERSION)
+ gio-2.0 >= $GIO_REQUIRED_VERSION)
],
[AC_MSG_FAILURE([Value for --with-gtk was neither 2 nor 3])]
)