aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Conti <jason.conti@gmail.com>2011-05-14 14:54:58 -0400
committerJason Conti <jason.conti@gmail.com>2011-05-14 14:54:58 -0400
commitd98fb2f1a159332f09026527ce833e3f4b73dd7a (patch)
tree8bd252be19a86692a522ed81a3124f1ef2eafbcf /configure.ac
parentd49b5573168cfbd524c9be40fc73396618ac6716 (diff)
downloadayatana-indicator-notifications-d98fb2f1a159332f09026527ce833e3f4b73dd7a.tar.gz
ayatana-indicator-notifications-d98fb2f1a159332f09026527ce833e3f4b73dd7a.tar.bz2
ayatana-indicator-notifications-d98fb2f1a159332f09026527ce833e3f4b73dd7a.zip
Adding gdk pixbuf to the deps for gtk2. Don't know what to use with gtk3 yet.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 69f1d0f..e1f352f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,6 +57,7 @@ GIO_REQUIRED_VERSION=2.25.11
# Note: the GIO check below also ensures the proper glib with gsettings support is present
INDICATOR_DISPLAY_OBJECTS=0.2.2
GDK_REQUIRED_VERSION=2.22
+GDK_PIXBUF_REQUIRED_VERSION=2.22
GLIB_REQUIRED_VERSION=2.26
GTK_REQUIRED_VERSION=2.12
GTK3_REQUIRED_VERSION=3.0
@@ -73,6 +74,7 @@ AS_IF([test "x$with_gtk" = x3],
glib-2.0 >= $GLIB_REQUIRED_VERSION
dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION
dbusmenu-gtk-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION
+ gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED_VERSION
libido-0.1 >= $INDICATOR_DISPLAY_OBJECTS)
],
[AC_MSG_FAILURE([Value for --with-gtk was neither 2 nor 3])]
@@ -89,11 +91,12 @@ AS_IF([test "x$with_gtk" = x3],
],
[test "x$with_gtk" = x2],
[PKG_CHECK_MODULES(SERVICE, indicator >= $INDICATOR_REQUIRED_VERSION
- glib-2.0 >= $GLIB_REQUIRED_VERSION
+ glib-2.0 >= $GLIB_REQUIRED_VERSION
dbusmenu-glib-0.4 >= $DBUSMENUGLIB_REQUIRED_VERSION
- dbusmenu-gtk-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION
+ dbusmenu-gtk-0.4 >= $DBUSMENUGTK_REQUIRED_VERSION
libido-0.1 >= $INDICATOR_DISPLAY_OBJECTS
gio-2.0 >= $GIO_REQUIRED_VERSION
+ gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED_VERSION
gdk-2.0 >= GDK_REQUIRED_VERSION)
],
[AC_MSG_FAILURE([Value for --with-gtk was neither 2 nor 3])]