aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2020-08-11 09:43:27 +0200
committerRobert Tari <robert@tari.in>2020-08-11 09:43:27 +0200
commitf15307a402dd66aff208ef9c79b54ae844324ad7 (patch)
tree9ef5dae755c81723082d8cca4c2b089904c8832f /configure.ac
parentd9fced125c2a6e1cf44171370753df00c8d554ba (diff)
parent7d7dc1140c38c22a629bc58238dff5cec17c30e5 (diff)
downloadayatana-indicator-notifications-f15307a402dd66aff208ef9c79b54ae844324ad7.tar.gz
ayatana-indicator-notifications-f15307a402dd66aff208ef9c79b54ae844324ad7.tar.bz2
ayatana-indicator-notifications-f15307a402dd66aff208ef9c79b54ae844324ad7.zip
Merge branch 'sunweaver-pr/sytemd-service-file'
Attributes GH PR #5: https://github.com/AyatanaIndicators/ayatana-indicator-notifications/pull/5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e9bc3bd..8b3b48b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,6 +65,19 @@ PKG_CHECK_MODULES(SETTINGS, gtk+-3.0 >= GTK3_REQUIRED_VERSION)
AC_SUBST(SETTINGS_CFLAGS)
AC_SUBST(SETTINGS_LIBS)
+#########################
+# Check for systemd
+#########################
+PKG_CHECK_MODULES(SYSTEMD, systemd,
+ [has_systemd=yes],
+ []
+)
+if test "x$has_systemd" = "xyes"; then
+ SYSTEMD_USERDIR=`$PKG_CONFIG --variable=systemduserunitdir systemd`
+ AC_SUBST(SYSTEMD_USERDIR)
+ AC_DEFINE(HAVE_SYSTEMD, 1, [create ayatana-indicator-application.service for systemd])
+fi
+
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_FILES([
Makefile