aboutsummaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
authorJason Conti <jason.conti@gmail.com>2013-02-17 22:38:46 -0500
committerJason Conti <jason.conti@gmail.com>2013-02-17 22:38:46 -0500
commit075774fe6081997a2c878ed19c7520c17790a279 (patch)
tree4cc08aa8fdd63dac9769440912bbf18f48d41c90 /data/Makefile.am
parent233e68ff2470d5317d8d44eb00bc3984e415d146 (diff)
downloadayatana-indicator-notifications-075774fe6081997a2c878ed19c7520c17790a279.tar.gz
ayatana-indicator-notifications-075774fe6081997a2c878ed19c7520c17790a279.tar.bz2
ayatana-indicator-notifications-075774fe6081997a2c878ed19c7520c17790a279.zip
* Add GSettings support.
- hide-indicator key to show/hide the indicator - max-items key to change the maximum number of displayed notifications
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 61a1a63..7299c5b 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -1 +1,21 @@
SUBDIRS = icons
+
+gsettings_file = net.launchpad.indicator.notifications.gschema.xml
+gsettings_SCHEMAS = $(gsettings_file)
+
+@INTLTOOL_XML_NOMERGE_RULE@
+
+$(gsettings_file).in: $(gsettings_file).in.in
+ sed \
+ -e "s|\@GETTEXT_PACKAGE\@|$(GETTEXT_PACKAGE)|" \
+ $< > $@
+
+@GSETTINGS_RULES@
+
+EXTRA_DIST = \
+ $(gsettings_file).in.in
+
+CLEANFILES = \
+ $(gsettings_file) \
+ $(gsettings_file).in \
+ *.gschema.valid