aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-02 19:19:37 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-02 19:19:37 +0100
commita559a648a96a4374c45b7aae999c3f0697f25f45 (patch)
treeff8e84622a6e6b98dd461f8ee83c5f59c1a5f5fc /debian/rules
parent6bc2b280c349851a05f28ca4b06fe5d51c59bea0 (diff)
downloadayatana-indicator-notifications-a559a648a96a4374c45b7aae999c3f0697f25f45.tar.gz
ayatana-indicator-notifications-a559a648a96a4374c45b7aae999c3f0697f25f45.tar.bz2
ayatana-indicator-notifications-a559a648a96a4374c45b7aae999c3f0697f25f45.zip
Import and adapt packaging from recent-notifications' ppa-indicator branch.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules21
1 files changed, 21 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..22435b7
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,21 @@
+#!/usr/bin/make -f
+
+DPKG_GENSYMBOLS_CHECK_LEVEL=4
+
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
+
+%:
+ dh $@ --with autoreconf
+
+override_dh_autoreconf:
+ NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+
+override_dh_auto_configure:
+ dh_auto_configure -- \
+ --disable-static
+
+override_dh_auto_install:
+ dh_auto_install
+ find debian/ayatana-indicator-notifications -name \*.la -delete