aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2022-01-13 11:19:50 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2022-01-27 09:28:42 +0100
commite626adea1ad5be2565164c5059f8d02c81f57c87 (patch)
treee4d1daf8ecbff8ed7645ca8e16afa23f11a68f90 /src/CMakeLists.txt
parentf9e30ebde987f006686555bbab219bc6fb01d156 (diff)
downloadayatana-indicator-notifications-e626adea1ad5be2565164c5059f8d02c81f57c87.tar.gz
ayatana-indicator-notifications-e626adea1ad5be2565164c5059f8d02c81f57c87.tar.bz2
ayatana-indicator-notifications-e626adea1ad5be2565164c5059f8d02c81f57c87.zip
Use Ayatana-style CMakeList + clean up compilation flags
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt16
1 files changed, 1 insertions, 15 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 9a19244..5bd56b5 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,6 +1,5 @@
set (SERVICE_LIB "ayatanaindicatornotificationsservice")
set (SERVICE_EXEC "ayatana-indicator-notifications-service")
-
add_definitions(-DG_LOG_DOMAIN="ayatana-indicator-notifications")
# handwritten sources
@@ -10,28 +9,15 @@ set(SERVICE_MANUAL_SOURCES
dbus-spy.c
service.c)
-# generated sources
-include(GdbusCodegen)
-set(SERVICE_GENERATED_SOURCES)
-
# add the bin dir to our include path so the code can find the generated header files
include_directories(${CMAKE_CURRENT_BINARY_DIR})
-
-# add warnings/coverage info on handwritten files
-# but not the autogenerated ones...
-set(C_WARNING_ARGS "${C_WARNING_ARGS} -Wno-bad-function-cast") # g_clear_object()
-set(C_WARNING_ARGS "${C_WARNING_ARGS} -Wno-switch-enum")
-set_source_files_properties(${SERVICE_MANUAL_SOURCES}
- PROPERTIES COMPILE_FLAGS "${C_WARNING_ARGS} -g -std=c99")
-
# the service library for tests to link against (basically, everything except main())
-add_library(${SERVICE_LIB} STATIC ${SERVICE_MANUAL_SOURCES} ${SERVICE_GENERATED_SOURCES})
+add_library(${SERVICE_LIB} STATIC ${SERVICE_MANUAL_SOURCES})
include_directories(${CMAKE_SOURCE_DIR})
link_directories(${SERVICE_DEPS_LIBRARY_DIRS})
# the executable: lib + main()
add_executable (${SERVICE_EXEC} main.c)
-set_source_files_properties(${SERVICE_SOURCES} main.c PROPERTIES COMPILE_FLAGS "${C_WARNING_ARGS} -std=c99")
target_link_libraries (${SERVICE_EXEC} ${SERVICE_LIB} ${SERVICE_DEPS_LIBRARIES})
install (TARGETS ${SERVICE_EXEC} RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_PKGLIBEXECDIR})