aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJason Conti <jason.conti@gmail.com>2019-06-08 17:38:00 -0400
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2019-08-28 11:18:48 +0200
commit55483b87132daf92ed65f531f648a7fec17bd733 (patch)
tree96a98834381e689dda8b68c1c129a8bd3d13386e /src/Makefile.am
parentfe7ea6190a1df5404b910d44d8b9abfcd9ef2fd1 (diff)
downloadayatana-indicator-notifications-55483b87132daf92ed65f531f648a7fec17bd733.tar.gz
ayatana-indicator-notifications-55483b87132daf92ed65f531f648a7fec17bd733.tar.bz2
ayatana-indicator-notifications-55483b87132daf92ed65f531f648a7fec17bd733.zip
* Add a settings UI
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 5cbce14..e89ade2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,10 +7,12 @@ libayatana_notifications_la_SOURCES = \
urlregex.h \
notification-menuitem.c \
notification-menuitem.h \
+ settings.h \
indicator-notifications.c \
notification.c \
notification.h
libayatana_notifications_la_CFLAGS = \
+ -DSETTINGS_PATH=\""$(libexecdir)/$(PACKAGE)/indicator-notifications-settings"\" \
$(INDICATOR_CFLAGS) \
-Wall \
-DG_LOG_DOMAIN=\"ayatana-indicator-notifications\"
@@ -20,3 +22,15 @@ libayatana_notifications_la_LDFLAGS = \
-module \
-avoid-version
+pkglibexec_PROGRAMS = indicator-notifications-settings
+
+indicator_notifications_settings_SOURCES = \
+ settings.h \
+ indicator-notifications-settings.c
+
+indicator_notifications_settings_CFLAGS = \
+ $(SETTINGS_CFLAGS) \
+ -Wall
+
+indicator_notifications_settings_LDADD = \
+ $(SETTINGS_LIBS)