aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJason Conti <jason.conti@gmail.com>2011-08-19 13:32:25 -0400
committerJason Conti <jason.conti@gmail.com>2011-08-19 13:32:25 -0400
commit59896497977040f03aaa0b2c293c265ed2e0c4e7 (patch)
tree4008e7001eb4835bdebc008162031df761a7434f /src/Makefile.am
parentc5ac5ce87d42d4456da3c82da1aed0ddece36129 (diff)
downloadayatana-indicator-notifications-59896497977040f03aaa0b2c293c265ed2e0c4e7.tar.gz
ayatana-indicator-notifications-59896497977040f03aaa0b2c293c265ed2e0c4e7.tar.bz2
ayatana-indicator-notifications-59896497977040f03aaa0b2c293c265ed2e0c4e7.zip
* Add a WITH_GTK (2, 3) definition to handle some of the minor differences0.1.3
between gtk2 and 3 * Replace gtk_hbox_new with gtk_box_new in the gtk3 version * GtkLabel has a new (and much nicer) wrapping mechanism - use gtk_label_set_max_width_chars in gtk3 version
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 486770f..708b030 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,5 @@
-AM_CPPFLAGS = -DICONS_DIR='"$(INDICATORICONSDIR)"'
+AM_CPPFLAGS = -DICONS_DIR='"$(INDICATORICONSDIR)"' \
+ -DWITH_GTK='$(GTK_VERSION)'
libexec_PROGRAMS = indicator-notifications-service