aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJason Conti <jason.conti@gmail.com>2011-08-29 11:11:43 -0400
committerJason Conti <jason.conti@gmail.com>2011-08-29 11:11:43 -0400
commitcb1da8552b56959f8f1c59a17fd4341f2aee611f (patch)
treeffe7c115e93253976ca04e2cf6743fe0d49c3088 /src/Makefile.am
parent467b817e26d75b156aacdaadc446de1a69b1a3fb (diff)
downloadayatana-indicator-notifications-cb1da8552b56959f8f1c59a17fd4341f2aee611f.tar.gz
ayatana-indicator-notifications-cb1da8552b56959f8f1c59a17fd4341f2aee611f.tar.bz2
ayatana-indicator-notifications-cb1da8552b56959f8f1c59a17fd4341f2aee611f.zip
* Simplified the indicator by removing the dbus service. Still needs:
- Clear button - Message limit * GTK3 is having issues with the multi-line menu items. Adding a bit of a hack to calculate the size of the menu and resize it when an item is added. Still has some problems, but better than before. Will probably cause other issues that will need to be addressed later.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am47
1 files changed, 5 insertions, 42 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2b92fc7..803402a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,32 +1,14 @@
AM_CPPFLAGS = -DICONS_DIR='"$(INDICATORICONSDIR)"' \
-DWITH_GTK='$(GTK_VERSION)'
-libexec_PROGRAMS = indicator-notifications-service
-
-indicator_notifications_service_SOURCES = \
- dbus-spy.c \
- dbus-spy.h \
- notification.c \
- notification.h \
- notifications-interface.c \
- notifications-interface.h \
- gen-notifications-service.xml.c \
- notifications-service.c \
- dbus-shared.h \
- settings-shared.h
-indicator_notifications_service_CFLAGS = \
- -Wall \
- $(SERVICE_CFLAGS) \
- -DG_LOG_DOMAIN=\"Indicator-Notifications\"
-indicator_notifications_service_LDADD = \
- $(SERVICE_LIBS)
-
notificationslibdir = $(INDICATORDIR)
notificationslib_LTLIBRARIES = libnotifications.la
libnotifications_la_SOURCES = \
- dbus-shared.h \
- settings-shared.h \
- indicator-notifications.c
+ dbus-spy.c \
+ dbus-spy.h \
+ indicator-notifications.c \
+ notification.c \
+ notification.h
libnotifications_la_CFLAGS = \
$(INDICATOR_CFLAGS) \
-Wall \
@@ -37,22 +19,3 @@ libnotifications_la_LDFLAGS = \
-module \
-avoid-version
-gen-notifications-service.xml.c: notifications-service.xml
- @echo "Building $@ from $<"
- @echo "const char * _notifications_service = " > $@
- @sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
- @echo ";" >> $@
-
-gen-notifications-service.xml.h: notifications-service.xml
- @echo "Building $@ from $<"
- @echo "extern const char * _notifications_service;" > $@
-
-BUILT_SOURCES = \
- gen-notifications-service.xml.c \
- gen-notifications-service.xml.h
-
-CLEANFILES = \
- $(BUILT_SOURCES)
-
-EXTRA_DIST = \
- notifications-service.xml