aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2020-11-08 13:50:13 +0100
committerRobert Tari <robert@tari.in>2020-11-10 12:10:27 +0100
commitf9a39b44803e6347c72c1edd8ba46f633e99dd57 (patch)
tree558d0879ddc9318f7e9c0bb7362fd7f086fa29f0 /src/Makefile.am
parentf872e9097ff373a172119bd3f7e9d0ef84b31ce1 (diff)
downloadayatana-indicator-notifications-f9a39b44803e6347c72c1edd8ba46f633e99dd57.tar.gz
ayatana-indicator-notifications-f9a39b44803e6347c72c1edd8ba46f633e99dd57.tar.bz2
ayatana-indicator-notifications-f9a39b44803e6347c72c1edd8ba46f633e99dd57.zip
Rewrite to indicator-ng, simplify, drop all GTK references, move to CMake
fixes #9, fixes #12
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am36
1 files changed, 0 insertions, 36 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
deleted file mode 100644
index e89ade2..0000000
--- a/src/Makefile.am
+++ /dev/null
@@ -1,36 +0,0 @@
-ayatananotificationslibdir = $(INDICATORDIR)
-ayatananotificationslib_LTLIBRARIES = libayatana-notifications.la
-libayatana_notifications_la_SOURCES = \
- dbus-spy.c \
- dbus-spy.h \
- urlregex.c \
- urlregex.h \
- notification-menuitem.c \
- notification-menuitem.h \
- settings.h \
- indicator-notifications.c \
- notification.c \
- notification.h
-libayatana_notifications_la_CFLAGS = \
- -DSETTINGS_PATH=\""$(libexecdir)/$(PACKAGE)/indicator-notifications-settings"\" \
- $(INDICATOR_CFLAGS) \
- -Wall \
- -DG_LOG_DOMAIN=\"ayatana-indicator-notifications\"
-libayatana_notifications_la_LIBADD = \
- $(INDICATOR_LIBS)
-libayatana_notifications_la_LDFLAGS = \
- -module \
- -avoid-version
-
-pkglibexec_PROGRAMS = indicator-notifications-settings
-
-indicator_notifications_settings_SOURCES = \
- settings.h \
- indicator-notifications-settings.c
-
-indicator_notifications_settings_CFLAGS = \
- $(SETTINGS_CFLAGS) \
- -Wall
-
-indicator_notifications_settings_LDADD = \
- $(SETTINGS_LIBS)