aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules32
1 files changed, 11 insertions, 21 deletions
diff --git a/debian/rules b/debian/rules
index 7382e4d..90fda29 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,35 +1,25 @@
#!/usr/bin/make -f
+# -*- makefile -*-
-DPKG_GENSYMBOLS_CHECK_LEVEL=4
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+export DPKG_GENSYMBOLS_CHECK_LEVEL=4
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
%:
- dh $@ --with autoreconf,systemd
-
-override_dh_autoreconf:
- if [ ! -e po/ayatana-indicator-notifications.pot.bak ]; then \
- cp po/ayatana-indicator-notifications.pot po/ayatana-indicator-notifications.pot.bak; \
- fi
- NOCONFIGURE=1 dh_autoreconf ./autogen.sh
-
-override_dh_auto_configure:
- dh_auto_configure -- \
- --disable-static
+ dh $@ --with systemd
-override_dh_auto_install:
- dh_auto_install
+override_dh_install:
find debian/ayatana-indicator-notifications -name \*.la -delete
+ find debian/ayatana-indicator-notifications -name \*.a -delete
+ dh_install --fail-missing
override_dh_installchangelogs:
dh_installchangelogs NEWS
-override_dh_auto_clean:
- dh_auto_clean
- if [ -e po/ayatana-indicator-notifications.pot.bak ]; then \
- mv -f po/ayatana-indicator-notifications.pot.bak po/ayatana-indicator-notifications.pot; \
- fi
- rm -f config.guess
- rm -f config.sub
+get-orig-source:
+ uscan --noconf --force-download --rename --download-current-version --destdir=..