aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am24
1 files changed, 0 insertions, 24 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 816c9fd..c92cece 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,9 +2,6 @@
libexec_PROGRAMS = indicator-example-service
indicator_example_service_SOURCES = \
- example-interface.c \
- example-interface.h \
- gen-example-service.xml.c \
example-service.c \
dbus-shared.h \
settings-shared.h
@@ -18,7 +15,6 @@ indicator_example_service_LDADD = \
examplelibdir = $(INDICATORDIR)
examplelib_LTLIBRARIES = libexample.la
libexample_la_SOURCES = \
- gen-example-service.xml.h \
dbus-shared.h \
settings-shared.h \
indicator-example.c
@@ -32,23 +28,3 @@ libexample_la_LDFLAGS = \
-module \
-avoid-version
-gen-%.xml.c: %.xml
- @echo "Building $@ from $<"
- @echo "const char * _$(subst -,_,$(subst .,_,$(basename $<))) = " > $@
- @sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
- @echo ";" >> $@
-
-gen-%.xml.h: %.xml
- @echo "Building $@ from $<"
- @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $<)));" > $@
-
-BUILT_SOURCES = \
- gen-example-service.xml.c \
- gen-example-service.xml.h
-
-
-CLEANFILES = \
- $(BUILT_SOURCES)
-
-EXTRA_DIST = \
- example-service.xml