aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 708b030..2b92fc7 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -37,15 +37,15 @@ libnotifications_la_LDFLAGS = \
-module \
-avoid-version
-gen-%.xml.c: %.xml
+gen-notifications-service.xml.c: notifications-service.xml
@echo "Building $@ from $<"
- @echo "const char * _$(subst -,_,$(subst .,_,$(basename $<))) = " > $@
+ @echo "const char * _notifications_service = " > $@
@sed -e "s:\":\\\\\":g" -e s:^:\": -e s:\$$:\\\\n\": $< >> $@
@echo ";" >> $@
-gen-%.xml.h: %.xml
+gen-notifications-service.xml.h: notifications-service.xml
@echo "Building $@ from $<"
- @echo "extern const char * _$(subst -,_,$(subst .,_,$(basename $<)));" > $@
+ @echo "extern const char * _notifications_service;" > $@
BUILT_SOURCES = \
gen-notifications-service.xml.c \