aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2023-11-04 11:18:24 +0100
committerRobert Tari <robert@tari.in>2023-11-04 11:18:24 +0100
commit0b8c415d7c86bb2f1f93fab017424c6778b80d8c (patch)
treea87a7e84c19f5e49f215066d2b95a6cf911279e9 /CMakeLists.txt
parent5a029486a08b5421586685c1e0fe16ff15093ba2 (diff)
parent55c6fbd978d2d6922a2cd72c422ae8c581268721 (diff)
downloadayatana-indicator-power-0b8c415d7c86bb2f1f93fab017424c6778b80d8c.tar.gz
ayatana-indicator-power-0b8c415d7c86bb2f1f93fab017424c6778b80d8c.tar.bz2
ayatana-indicator-power-0b8c415d7c86bb2f1f93fab017424c6778b80d8c.zip
Merge branch 'sunweaver-pr/rda-optional'
Attributes GH PR #89: https://github.com/AyatanaIndicators/ayatana-indicator-power/pull/89
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d278421..ba9f80a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,6 +16,7 @@ option(ENABLE_COVERAGE "Enable coverage reports (includes enabling all tests and
option(ENABLE_WERROR "Treat all build warnings as errors" OFF)
option(ENABLE_LOMIRI_FEATURES "Build with Lomiri-specific libraries, schemas and media" OFF)
option(ENABLE_DEVICEINFO "Build with deviceinfo integration" OFF)
+option(ENABLE_RDA "Build with RDA (remote desktop awareness) support" ON)
if(ENABLE_COVERAGE)
set(ENABLE_TESTS ON)
@@ -73,7 +74,6 @@ set(
gio-unix-2.0>=2.36
libnotify>=0.7.6
libayatana-common>=0.9.1
- rda
)
if (ENABLE_LOMIRI_FEATURES)
@@ -90,6 +90,17 @@ if (ENABLE_LOMIRI_FEATURES)
)
endif ()
+if (ENABLE_RDA)
+ list (
+ APPEND
+ SERVICE_DEPS
+ rda
+ )
+ add_definitions (
+ -DRDA_ENABLED
+ )
+endif ()
+
pkg_check_modules (SERVICE_DEPS REQUIRED ${SERVICE_DEPS})
include_directories (SYSTEM ${SERVICE_DEPS_INCLUDE_DIRS})