aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2016-01-04 09:38:01 -0600
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-08-28 10:17:14 +0200
commit1182c7fb79942c14f2a713063182778e6af94cd1 (patch)
tree8868f158ed71d8e97e79220a42c590fa6a44666d /CMakeLists.txt
parent5d038638f58765ec3859797704c5d0e1c0fa7903 (diff)
downloadayatana-indicator-power-1182c7fb79942c14f2a713063182778e6af94cd1.tar.gz
ayatana-indicator-power-1182c7fb79942c14f2a713063182778e6af94cd1.tar.bz2
ayatana-indicator-power-1182c7fb79942c14f2a713063182778e6af94cd1.zip
add build-dep to accountsservice-ubuntu-schemas instead of bundling com.ubuntu.touch.AccountsService.Sound.xml into our source tree
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3d59545..bc5729a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,6 +69,13 @@ pkg_check_modules(
)
include_directories(${URLDISPATCHER_INCLUDE_DIRS})
+if(EXISTS "/usr/share/accountsservice/interfaces/com.ubuntu.touch.AccountsService.Sound.xml")
+ set (HAVE_UT_ACCTSERVICE_SYSTEMSOUND_SETTINGS ON)
+ add_definitions ( -DHAS_UT_ACCTSERVICE_SYSTEMSOUND_SETTINGS )
+else()
+ set (HAVE_UT_ACCTSERVICE_SYSTEMSOUND_SETTINGS OFF)
+endif()
+
##
## custom targets
##