aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2021-11-24 10:11:34 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-12-15 14:34:47 +0100
commit14726b036bd6d87a1aa601c6de34584ee8412788 (patch)
treeae0f03d5fcd5634fc54e2721e57aefc1c1135952 /CMakeLists.txt
parent01b36c885849a0af262a381469a394f4c9979cda (diff)
downloadayatana-indicator-power-14726b036bd6d87a1aa601c6de34584ee8412788.tar.gz
ayatana-indicator-power-14726b036bd6d87a1aa601c6de34584ee8412788.tar.bz2
ayatana-indicator-power-14726b036bd6d87a1aa601c6de34584ee8412788.zip
Check for lomiri-schemas package instead of individual files
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4937ae4..1de415a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -68,11 +68,10 @@ pkg_check_modules(SERVICE_DEPS REQUIRED
include_directories (SYSTEM ${SERVICE_DEPS_INCLUDE_DIRS})
-if(EXISTS "/usr/share/accountsservice/interfaces/com.lomiri.touch.AccountsService.Sound.xml")
- set (HAS_LOMIRI_ACCTSERVICE_SOUND ON)
- add_definitions ( -DHAS_LOMIRI_ACCTSERVICE_SOUND )
-else()
- set (HAS_LOMIRI_ACCTSERVICE_SOUND OFF)
+pkg_check_modules(LOMIRI_SCHEMAS lomiri-schemas)
+
+if(LOMIRI_SCHEMAS_FOUND)
+ add_definitions ( -DHAS_LOMIRI_SCHEMAS )
endif()
##