aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2016-05-16 12:59:03 -0500
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-08-28 10:17:14 +0200
commit39571b0e05c78627d233b2f77250de459d73f4a6 (patch)
tree275260eeace7790c5763d3ed8668386e417d7e24 /CMakeLists.txt
parent557e10a031b886dc670bdf5918c3984edbace5ac (diff)
downloadayatana-indicator-power-39571b0e05c78627d233b2f77250de459d73f4a6.tar.gz
ayatana-indicator-power-39571b0e05c78627d233b2f77250de459d73f4a6.tar.bz2
ayatana-indicator-power-39571b0e05c78627d233b2f77250de459d73f4a6.zip
fix cmake warning of the test apps' dependency on the service library
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 10 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bc5729a..258a111 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -40,14 +40,21 @@ set (CMAKE_INSTALL_FULL_PKGLIBEXECDIR "${CMAKE_INSTALL_FULL_LIBEXECDIR}/${CMAKE_
##
set(GETTEXT_PACKAGE "ayatana-indicator-power")
-add_definitions (-DGETTEXT_PACKAGE="${GETTEXT_PACKAGE}"
- -DLOCALEDIR="${CMAKE_INSTALL_FULL_LOCALEDIR}"
- -DLOW_BATTERY_SOUND="Low battery.ogg")
+add_definitions(
+ -DGETTEXT_PACKAGE="${GETTEXT_PACKAGE}"
+ -DG_LOG_DOMAIN="${GETTEXT_PACKAGE}"
+ -DLOCALEDIR="${CMAKE_INSTALL_FULL_LOCALEDIR}"
+ -DLOW_BATTERY_SOUND="Low battery.ogg"
+)
##
## Check for prerequisites
##
+set(SERVICE_LIB "ayatanaindicatorpowerservice")
+set(SERVICE_EXEC "ayatana-indicator-power-service")
+add_definitions(-DSERVICE_EXEC="${SERVICE_EXEC}")
+
find_package (PkgConfig REQUIRED)
include (CheckIncludeFile)
include (FindPkgConfig)