aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2020-07-24 12:08:07 +0200
committerRobert Tari <robert@tari.in>2020-07-24 18:52:05 +0200
commit653137a083c64d2003263351d3c5da2ecc7bb64a (patch)
tree3f6fa6c0eabc274edb6bdec363b0cfb6981f941f /CMakeLists.txt
parent97d211af7c95f1365c0aa7742094d8419db4c7dc (diff)
downloadayatana-indicator-power-653137a083c64d2003263351d3c5da2ecc7bb64a.tar.gz
ayatana-indicator-power-653137a083c64d2003263351d3c5da2ecc7bb64a.tar.bz2
ayatana-indicator-power-653137a083c64d2003263351d3c5da2ecc7bb64a.zip
CMakeLists.txt: Drop workaround for missing libexec dir on Debian. Debian moved forward and now supports FHS 3.0 (since Debian Policy 4.1.5).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2a4450f..ed78b11 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,10 +11,6 @@ set(PACKAGE ${CMAKE_PROJECT_NAME})
##
include (GNUInstallDirs)
-if (EXISTS "/etc/debian_version") # Workaround for libexecdir on debian
- set (CMAKE_INSTALL_LIBEXECDIR "${CMAKE_INSTALL_LIBDIR}")
- set (CMAKE_INSTALL_FULL_LIBEXECDIR "${CMAKE_INSTALL_FULL_LIBDIR}")
-endif ()
set (CMAKE_INSTALL_PKGLIBEXECDIR "${CMAKE_INSTALL_LIBEXECDIR}/${CMAKE_PROJECT_NAME}")
set (CMAKE_INSTALL_FULL_PKGLIBEXECDIR "${CMAKE_INSTALL_FULL_LIBEXECDIR}/${CMAKE_PROJECT_NAME}")