aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRodney <6557070+dobey@users.noreply.github.com>2018-10-28 13:54:40 -0400
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-08-28 10:17:14 +0200
commit948a5107c479a72a2940316674fae6a3b55534ff (patch)
treecd67de6aa39e19f27386058b9499e3e295b46bf7 /CMakeLists.txt
parentecb73d5a817e47598635523bfb04a8ac9c7ac5a9 (diff)
downloadayatana-indicator-power-948a5107c479a72a2940316674fae6a3b55534ff.tar.gz
ayatana-indicator-power-948a5107c479a72a2940316674fae6a3b55534ff.tar.bz2
ayatana-indicator-power-948a5107c479a72a2940316674fae6a3b55534ff.zip
Pull in many fixes from the bionic branch. (#7)
* Pay attention to $SNAP prefix * Releasing 12.10.6+17.04.20161201-0ubuntu1 * give sorting priority to devices with power supplies * Releasing 12.10.6+17.04.20170116-0ubuntu1 * Remove old autostart files. * Use gmock module from cmake-extras. * Use coverage support from cmake-extras. * Add gcovr and lcov dependencies. * Use intltool support from cmake-extras. * Remove usage of extra GCOV variables. * Remove hard-coded -g compiler flag. * Releasing 12.10.6+17.04.20170210-0ubuntu1 * no change rebuild * Releasing 12.10.6+17.04.20170322-0ubuntu1 * Start indicator in systemd when indicators.target is started * Build for bionic * This is still xenial. * Update translations from launchpad too.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 956c724..72f4bde 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -125,7 +125,7 @@ if (ENABLE_TESTS)
if (ENABLE_COVERAGE)
find_package(CoverageReport)
ENABLE_COVERAGE_REPORT(
- TARGETS ayatanaindicatorpowerservice ayatana-indicator-power-service
+ TARGETS ${SERVICE_LIB} ${SERVICE_EXEC}
TESTS ${COVERAGE_TEST_TARGETS}
FILTER /usr/include ${CMAKE_BINARY_DIR}/*
)