aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2021-08-09 21:48:17 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-08-10 21:49:38 +0200
commitb0737af925f4872db0952e2fefe16d14b4f8cf4f (patch)
tree4f3b8fce7719c5702d13bde76426f3ac1caab1f9 /CMakeLists.txt
parenta3361b8fe0ce9d803fa0574ab8a46fd8cff01871 (diff)
downloadayatana-indicator-power-b0737af925f4872db0952e2fefe16d14b4f8cf4f.tar.gz
ayatana-indicator-power-b0737af925f4872db0952e2fefe16d14b4f8cf4f.tar.bz2
ayatana-indicator-power-b0737af925f4872db0952e2fefe16d14b4f8cf4f.zip
Add ENABLE_WERROR option
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 24f800e..9cc29fe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,7 @@ set(PACKAGE ${CMAKE_PROJECT_NAME})
# Options
option(ENABLE_TESTS "Enable all tests and checks" OFF)
option(ENABLE_COVERAGE "Enable coverage reports (includes enabling all tests and checks)" OFF)
+option(ENABLE_WERROR "Treat all build warnings as errors" OFF)
if(ENABLE_COVERAGE)
set(ENABLE_TESTS ON)
@@ -21,6 +22,11 @@ else()
set(CMAKE_BUILD_TYPE "Release")
endif()
+if(ENABLE_WERROR)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
+endif()
+
##
## GNU standard installation directories
##
@@ -115,3 +121,4 @@ endif ()
message(STATUS "Install prefix: ${CMAKE_INSTALL_PREFIX}")
message(STATUS "Unit tests: ${ENABLE_TESTS}")
+message(STATUS "Build with -Werror: ${ENABLE_WERROR}")