aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMuhammad <muhammad23012009@hotmail.com>2023-05-12 17:49:30 +0500
committerMuhammad <muhammad23012009@hotmail.com>2023-06-05 23:01:18 +0500
commitdd3dccb5b3ece993ea648f76ff0cc9aa08527061 (patch)
tree1af9ef4b73a3657774bc161a05a5d3bb1a11ca4a /CMakeLists.txt
parent08039f0bfcd35efca2a075bbf49fe3e45d89d5bf (diff)
downloadayatana-indicator-power-dd3dccb5b3ece993ea648f76ff0cc9aa08527061.tar.gz
ayatana-indicator-power-dd3dccb5b3ece993ea648f76ff0cc9aa08527061.tar.bz2
ayatana-indicator-power-dd3dccb5b3ece993ea648f76ff0cc9aa08527061.zip
src: add support for getting flashlight paths through deviceinfo
Signed-off-by: Muhammad <muhammad23012009@hotmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1a9ee67..18a9152 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,7 @@ option(ENABLE_TESTS "Enable all tests and checks" OFF)
option(ENABLE_COVERAGE "Enable coverage reports (includes enabling all tests and checks)" OFF)
option(ENABLE_WERROR "Treat all build warnings as errors" OFF)
option(ENABLE_LOMIRI_FEATURES "Build with Lomiri-specific libraries, schemas and media" OFF)
+option(ENABLE_DEVICEINFO "Build with deviceinfo integration" OFF)
if(ENABLE_COVERAGE)
set(ENABLE_TESTS ON)
@@ -91,6 +92,11 @@ endif ()
pkg_check_modules (SERVICE_DEPS REQUIRED ${SERVICE_DEPS})
include_directories (SYSTEM ${SERVICE_DEPS_INCLUDE_DIRS})
+if (ENABLE_DEVICEINFO)
+ pkg_check_modules (DEVICEINFO IMPORTED_TARGET "deviceinfo")
+ include_directories (${DEVICEINFO_INCLUDE_DIRS})
+endif ()
+
##
## custom targets
##