aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2011-08-23 12:44:57 -0400
committerKen VanDine <ken.vandine@canonical.com>2011-08-23 12:44:57 -0400
commit3751cc4b823c5d701456317bb86fc4fc39bf3b9e (patch)
tree6725806cef45179dc405df717806ea42b7bba6af /Makefile.am
parentedfb2ab89822da16fc1150a5350c130830a733b3 (diff)
parentb1a5f6eda8a4b41773e2e7247c2e2a57300a9f9e (diff)
downloadayatana-indicator-power-3751cc4b823c5d701456317bb86fc4fc39bf3b9e.tar.gz
ayatana-indicator-power-3751cc4b823c5d701456317bb86fc4fc39bf3b9e.tar.bz2
ayatana-indicator-power-3751cc4b823c5d701456317bb86fc4fc39bf3b9e.zip
Import upstream version 0.7
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 932775f..8ae7e6d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,13 @@ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
SUBDIRS = po
+gsettings_in_file = data/org.ubuntu.indicator-power.gschema.xml.in
+gsettings_SCHEMAS = $(gsettings_in_file:.xml.in=.xml)
+
+@INTLTOOL_XML_NOMERGE_RULE@
+
+@GSETTINGS_RULES@
+
###################
# Indicator Stuff
###################
@@ -24,7 +31,18 @@ libpower_la_LDFLAGS = \
############################################################
-EXTRA_DIST = autogen.sh
+dist_noinst_SCRIPTS = \
+ autogen.sh
+
+dist_noinst_DATA = \
+ data/org.ubuntu.indicator-power.gschema.xml
+ $(gsettings_in_file)
+
+CLEANFILES = \
+ $(gsettings_SCHEMAS)
+
+MAINTAINERCLEANFILES = \
+ $(gsettings_SCHEMAS:.xml=.valid)
DISTCHECK_CONFIGURE_FLAGS = --enable-localinstall