aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKen VanDine <ken.vandine@canonical.com>2011-07-08 09:59:03 -0400
committerKen VanDine <ken.vandine@canonical.com>2011-07-08 09:59:03 -0400
commit539a65b516b734a01d250c80f83469537575d76d (patch)
tree44782f06f7dbeb8d67ff88db93144c3d9f62f05d /configure.ac
parent7c7458bb89015be2bbeea18a96a5f3c6a1af141d (diff)
parent502f3f9dc58ddbe9ccae645d5e29fb0e7c09a65d (diff)
downloadayatana-indicator-power-539a65b516b734a01d250c80f83469537575d76d.tar.gz
ayatana-indicator-power-539a65b516b734a01d250c80f83469537575d76d.tar.bz2
ayatana-indicator-power-539a65b516b734a01d250c80f83469537575d76d.zip
New upstream release.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac32
1 files changed, 8 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 1e882e6..b8724b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
AC_INIT([indicator-power],
- [0.1],
+ [0.2],
[http://bugs.launchpad.net/indicator-power],
[indicator-power],
[http://launchpad.net/indicator-power])
@@ -30,13 +30,13 @@ LT_INIT
###########################
GTK_REQUIRED_VERSION=3.0
-INDICATOR_REQUIRED_VERSION=0.3.0
+INDICATOR_REQUIRED_VERSION=0.3.90
UPOWER_REQUIRED_VERSION=0.9.5
PKG_CHECK_MODULES([UPOWER],[upower-glib >= UPOWER_REQUIRED_VERSION])
PKG_CHECK_MODULES([INDICATOR],[
gtk+-3.0 >= $GTK_REQUIRED_VERSION
- indicator3 >= $INDICATOR_REQUIRED_VERSION
+ indicator3-0.4 >= $INDICATOR_REQUIRED_VERSION
])
###########################
@@ -54,30 +54,14 @@ AC_ARG_ENABLE([localinstall],
# Indicator Info
###########################
-if test "x$with_localinstall" = "xyes"; then
- INDICATORDIR="${libdir}/indicators/3/"
- INDICATORICONSDIR="${datadir}/indicator-applet/icons/"
-elif test "x$with_gtk" = x2; then
- INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator`
- INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator`
-else
- INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator3`
- INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator3`
-fi
+AS_IF([test "x$with_localinstall" = "xyes"],
+ [INDICATORDIR="${libdir}/indicators3/2/"
+ INDICATORICONSDIR="${datadir}/indicator-applet/icons/"],
+ [INDICATORDIR=`$PKG_CONFIG --variable=indicatordir indicator3-0.4`
+ INDICATORICONSDIR=`$PKG_CONFIG --variable=iconsdir indicator3-0.4`])
AC_SUBST(INDICATORDIR)
AC_SUBST(INDICATORICONSDIR)
-###########################
-# DBus Service Info
-###########################
-
-if test "x$with_localinstall" = "xyes"; then
- DBUSSERVICEDIR="${datadir}/dbus-1/services/"
-else
- DBUSSERVICEDIR=`$PKG_CONFIG --variable=session_bus_services_dir dbus-1`
-fi
-AC_SUBST(DBUSSERVICEDIR)
-
##############################
# Custom Junk
##############################