aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorIain Lane <iain.lane@canonical.com>2014-04-15 14:43:09 +0100
committerIain Lane <iain.lane@canonical.com>2014-04-15 14:43:09 +0100
commitfb4c324c76176b248c40bce6f151bd397f8e09fb (patch)
tree38f28c3b5e41d013365a9e48345e1c760ff268ee /debian/rules
parentdb0257786292c682cace8ebecf1f528ba2076fe4 (diff)
downloadayatana-indicator-power-fb4c324c76176b248c40bce6f151bd397f8e09fb.tar.gz
ayatana-indicator-power-fb4c324c76176b248c40bce6f151bd397f8e09fb.tar.bz2
ayatana-indicator-power-fb4c324c76176b248c40bce6f151bd397f8e09fb.zip
Don't build the tests when cross compiling, they fail to build
AC_CHECK_FILES doesn't work when cross building for some reason. But we don't run the tests in this situation anyway, so don't worry about it.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 9 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 83edd94..36a22d7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,12 +6,21 @@
export DPKG_GENSYMBOLS_CHECK_LEVEL=4
+ifeq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
+ TESTS=yes
+else
+ TESTS=no
+endif
+
%:
dh $@ --with autoreconf
override_dh_autoreconf:
NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+override_dh_auto_configure:
+ dh_auto_configure -- --enable-tests=$(TESTS)
+
override_dh_install:
find debian/indicator-power -name \*.la -delete
find debian/indicator-power -name \*.a -delete