aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-02 20:55:20 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2017-12-02 20:55:20 +0100
commite9b7bfe3edef801c15f5186f2cd6e9fd7bed9cdc (patch)
treef0197a0359a4419f9cc4354afd379c72d1427650 /debian
parent0f2a468c34f6ff9382af78ff1591f24b7bb9c620 (diff)
downloadayatana-indicator-power-e9b7bfe3edef801c15f5186f2cd6e9fd7bed9cdc.tar.gz
ayatana-indicator-power-e9b7bfe3edef801c15f5186f2cd6e9fd7bed9cdc.tar.bz2
ayatana-indicator-power-e9b7bfe3edef801c15f5186f2cd6e9fd7bed9cdc.zip
debian/{control,postinst}: Recompile GSettings schemas at post installation.
Diffstat (limited to 'debian')
-rw-r--r--debian/control1
-rw-r--r--debian/postinst40
2 files changed, 41 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index 8b3cbbf..26aeb50 100644
--- a/debian/control
+++ b/debian/control
@@ -29,6 +29,7 @@ Depends: ${shlibs:Depends},
${misc:Depends},
ayatana-indicator-common,
upower,
+ glib2.0-bin,
Recommends: unity-control-center | gnome-control-center (>= 3.1) | ubuntu-system-settings | switchboard-plug-power | xfce4-power-manager | mate-power-manager,
mate-indicator-applet | xfce4-indicator-plugin,
Suggests: powerd,
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 0000000..afded24
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,40 @@
+#!/bin/sh
+# postinst script for ayatana-indicator-power
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <postinst> `configure' <most-recently-configured-version>
+# * <old-postinst> `abort-upgrade' <new version>
+# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+# <new-version>
+# * <postinst> `abort-remove'
+# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+# <failed-install-package> <version> `removing'
+# <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+
+case "$1" in
+ configure)
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0