aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-03-12 14:34:44 +0100
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2018-03-12 18:33:03 +0100
commit422443fc5c653bfd68aad90a2556a62f1edf1333 (patch)
tree72c941cdab3684b982da1b6e4053aaf0623a2821 /src/CMakeLists.txt
parent4d9589837e532df1015f7579439703c0af0164ca (diff)
downloadayatana-indicator-power-422443fc5c653bfd68aad90a2556a62f1edf1333.tar.gz
ayatana-indicator-power-422443fc5c653bfd68aad90a2556a62f1edf1333.tar.bz2
ayatana-indicator-power-422443fc5c653bfd68aad90a2556a62f1edf1333.zip
Make URL dispatcher build-dependency optional and handle battery settings request appropriately.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 2faedd6..d803f1e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -3,6 +3,10 @@ set (SERVICE_EXEC "ayatana-indicator-power-service")
add_definitions(-DG_LOG_DOMAIN="ayatana-indicator-power")
+if(URLDISPATCHER_FOUND)
+ add_definitions( -DHAS_URLDISPATCHER )
+endif()
+
# handwritten sources
set(SERVICE_MANUAL_SOURCES
brightness.c
@@ -12,7 +16,8 @@ set(SERVICE_MANUAL_SOURCES
device.c
notifier.c
testing.c
- service.c)
+ service.c
+ utils.c)
# generated sources
include(GdbusCodegen)
@@ -51,5 +56,5 @@ link_directories(${SERVICE_DEPS_LIBRARY_DIRS})
# the executable: lib + main()
add_executable (${SERVICE_EXEC} main.c)
set_source_files_properties(${SERVICE_SOURCES} main.c PROPERTIES COMPILE_FLAGS "${C_WARNING_ARGS} -g -std=c99")
-target_link_libraries (${SERVICE_EXEC} ${SERVICE_LIB} ${SERVICE_DEPS_LIBRARIES} ${GCOV_LIBS})
+target_link_libraries (${SERVICE_EXEC} ${SERVICE_LIB} ${SERVICE_DEPS_LIBRARIES} ${GCOV_LIBS} ${URLDISPATCHER_LIBRARIES})
install (TARGETS ${SERVICE_EXEC} RUNTIME DESTINATION ${CMAKE_INSTALL_FULL_PKGLIBEXECDIR})