aboutsummaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorcharles kerr <charlesk@canonical.com>2016-01-01 20:08:05 -0600
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-08-28 10:17:14 +0200
commit97130ad08300c3ec6ab2165ff7506cd7f25af0d6 (patch)
tree58a988880a81563e1cdc4fadcd74c2e50a59d63a /src/CMakeLists.txt
parent460f1464709a4c5e2c1594045961be9108ae2afd (diff)
downloadayatana-indicator-power-97130ad08300c3ec6ab2165ff7506cd7f25af0d6.tar.gz
ayatana-indicator-power-97130ad08300c3ec6ab2165ff7506cd7f25af0d6.tar.bz2
ayatana-indicator-power-97130ad08300c3ec6ab2165ff7506cd7f25af0d6.zip
honor com.ubuntu.touch.AccountsService.Sound.SilentMode
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index c99ce46..01a0558 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -39,6 +39,11 @@ add_gdbus_codegen_with_namespace(SERVICE_GENERATED_SOURCES dbus-testing
org.ayatana.indicator.power
Dbus
${CMAKE_SOURCE_DIR}/data/org.ayatana.indicator.power.Testing.xml)
+add_gdbus_codegen_with_namespace(SERVICE_GENERATED_SOURCES dbus-accounts-sound
+ com.ubuntu.touch
+ Dbus
+ ${CMAKE_SOURCE_DIR}/src/com.ubuntu.touch.AccountsService.Sound.xml)
+
# add the bin dir to our include path so the code can find the generated header files
include_directories(${CMAKE_CURRENT_BINARY_DIR})